niedziela, 19 września

Apple ostrzega użytkowników, że niektóre z najważniejszych funkcji systemowych i wiele aplikacji innych firm na starszych urządzeniach iPhone lub iPad przestaną działać 3 listopada, chyba że zaktualizują swoje urządzenia.

Wynika to z problemu wyzerowania czasu GPS, który zaczął oddziaływać na produkty GPS innych producentów 6 kwietnia 2019 roku. Teraz Apple ostrzega użytkowników, że ten sam problem wpłynie na niektóre iPhone’y i iPady tuż przed północą 3 listopada 2019 r. Zasadniczo dzieje się tak, ponieważ sieć globalnego systemu pozycjonowania sygnalizuje czasowo swoje dane w sposób, który pozwala mu dotrzeć do 1023 tygodni przed powrotem do zera.

„Jeśli do 3 listopada roku nie uaktualnisz oprogramowania do najnowszej wersji systemu iOS dostępnej dla danego urządzenia, niektóre modele mogą nie wskazywać poprawnego położenia GPS. Również funkcje polegające na poprawnej dacie i godzinie — takie jak synchronizowanie z usługą iCloud i pobieranie poczty e-mail — mogą nie działać.”

Problem spowoduje, że niektóre modele iPhone’a i iPada wprowadzone w 2012 roku i wcześniejszych utracą funkcjonalność GPS. Nie brzmi to może bardzo poważnie, dopóki nie zorientujecie się, ile funkcji systemu opiera się na GPS.

Oprócz utraty możliwości geolokalizacji za pomocą GPS, te modele iPhone’a i iPada mogą być ustawione na nieprawidłowe czasy – co spowoduje problemy z pobieraniem wiadomości e-mail i synchronizacją z iCloud. Aplikacje innych firm, które korzystają z GPS lub prawidłowych ustawień czasu, również mogą ulec awarii w tym dniu.

Na szczęście dotyczy to tylko niektórych modeli iPhone’a i iPada. Wpłynie to na przykład tylko na iPady z obsługą sieci komórkowej. Pełna lista urządzeń obejmuje:

  • iPhone 5
  • iPad (czwartej generacji)
  • iPhone 4s
  • iPad mini (pierwszej generacji)
  • iPad 2 (tylko modele CDMA)
  • iPad (trzeciej generacji)

Aby uniknąć błędu iPhone 5 i iPad czwartej generacji będą wymagały aktualizacji do iOS 10.3.4. Reszta urządzeń musi zostać zaktualizowana do wersji iOS 9.3.6. Problem nie dotyczy iPoda touch ani żadnego modelu iPada obsługującego tylko funkcję Wi-Fi. Nie dotyczy też urządzeń z systemem iOS, których nie ma na powyższej liście.

Warto również zauważyć, że najstarsze iPhone’y i iPady, czyli starsze od tych wymienionych na liście nie będą mogły otrzymać aktualizacji tego błędu. W związku z tym użytkownicy tych urządzeń będą musieli znosić konsekwencje błędu.

Udostępnij:
Subscribe
Powiadom o
guest
0 komentarzy
Inline Feedbacks
View all comments
0
Chciałbyś się podzielić swoim przemyśleniem? Zostaw komentarzx
()
x